読者です 読者をやめる 読者になる 読者になる

Mavericks に cvs がなかったのでインストールした

Macにemacs-w3mを入れようとしたら、cvsコマンドがなかった。

どうやら Mavericks からはインストールされていないようす?
なので、インストールしました。

$ sudo port install cvs

エラーでました。

Error: org.macports.extract for port zlib returned: command execution failed
Error: Failed to install zlib
Please see the log file for port zlib for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_zlib/zlib/main.log
Error: The following dependencies were not installed: zlib
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade openssl failed

zlibが入らない?とかウンウン言われて、色々試しましたが、
結局 Macports をアップデートしていなかったのが原因だったよう。

$ sudo port selfupdate
$ sudo port install cvs

無事、インストールできました。

$ which cvs
/opt/local/bin/cvs